System Messages

This forum is for members of the Apiary Investment Fund. To learn more about how to get involved, sign up now or fill out the form below and preview the training right now!

Apiary Fund mobile App

Back to Forums

Apiary Fund mobile App

I am having trouble getting the dashboard to load on my mobile phone with the mobile app.  Has anyone had this problem?  Is there anything that can be done for this?  I am also getting the error messages "error fetching achievements" and "error fetching order history"

Any assistance would be greatly appreciated.

Tue, 01/19/2016 - 2:10pm
Jason Mertz

Did you have any of your accounts "reset" recently?

I had some of my accounts reset the other day and I wasn't able to load mine until I placed the first trade in that particular account. It was also the last account I had pulled it kept crashing every time I tried to load it (i guess because it couldn't find any orders to retrieve?)...until I placed a trade...then it opened fine.


I have been having the same issue, errors & all. I am brand new & am still even in my trial period. I sent a tech support message, but have not heard anything back.

Jason Mertz

btw, I am using the Iphone app.

@Mo money, have you placed a trade yet? If not, try that...if so...I don't know... :(


I was getting that message until I had completed a trade.


I've been getting the error fetching achievements problem for a long time now, just kind of gave up on the whole mobile app really.


i just bought an iphone and it loads every time all my android devices rarely work


Problems still there. Really hurts when you cannot manage your trades


Make sure under account on the top left you see your correct account number, if not change it and it should work then. (NOTE: You must have had at least one trade on the account when you switch)


I was told by a customer service person who had a hard time understanding my issue like it was a language barrier (I'm just stating a fact not logging a complaint ) . She finally put me on hold and came back with " the Android phones don't work on the mobile app yet."
It worked one time for me after download (?- or before on the test sample ) and I loved it , so hope this gets resolved ....would be great to have contact from anywhere .


the mobile app shows the wrong stats on open trades all the time and gets good then just freezes up ..something i have had to learn to work around. it sucks but its what we have to work with at the moment!

Jason Mertz

Last I heard on Iphone it works...but it is not currently producing live it only updates every minute or so...It is NOT currently updating with each "refresh".

They plan to get back to that at some point though. Agree flashigpips...better than nothing.


Support told me they are busy trying to handle liquidity connections, and providers. Phone app on back burner.

Hasan F

Found some workarounds for this problem. I sent this to Tech Support.

"Hi guys,

I'm in California and I've downloaded the Apiary Fund app on my Samsung Galaxy S5 (Sprint) and originally it was not working. But I've figured out a workaround that allows it to load my statistics and orders every single time. I just toggle to the Account tab and hit Sign Out. When I log back in it loads up my statistics and orders.

If I close the app without signing out, then the next time I open it up it will fail when trying to load my information. Once again signing out and signing back in saves the day.

I believe the issue with the app (on Android) has specifically to do with the passcode. When trying to verify credentials using only the passcode, it fails to load user information, but a full sign out and sign in works.

My suggestion: If you could abandon the passcode feature for now I think the issues you are having on Android will be fixed.

Hope this helps."


I tried download the mobile app, it says it could not found in your country or region.
Does anybody in country other than US have this issue? I am in Canada.
How can I do?

Any idea would be helpful.


I cannot even see the app on Google Play Store. Please is it there?


Gozy, support told me the apps broke at the moment.
I replied back asking is there any roughly timeframe fix the issue.