System Messages

This forum is for members of the Apiary Investment Fund. To learn more about how to get involved,
sign up now for a 14 day free trial or fill out the form below and preview the training right now!

Poor customer service

 
Back to Forums
 
 
lah533p

Poor customer service

Has anyone else experienced trades not closing at take profit targets? And tasks being counted one day and then not the next? I’m British and so used to poor customer service but this recent debacle is the so frustrating. Had 10 trades all entered at the same time and same take profit level- 8 closed fine, 2 didn’t. Told it was an Alveo glitch so how can I be responsible for that!!! This morning looked like I’d made a task only to find, a couple of hours later, that I’d gone back to the beginning of the task! What is going on???? I’ve never been an Alveo fan, it’s way too restrictive, but come on Apiary Fund. If you want us to make money give us something professional to work with!!!

Thu, 03/28/2019 - 11:42am
 
dantheman

If you have documentation that a trade didn't close and should have, like in this case, then you can request it be removed from your order history. I did that once where it lost connection with the LP before my TP and then connection came back below my SL. It set back one of my Beeline tasks. They removed it and my competition came back. I haven't been in touch with Apiary support that much. but the few times I have they've always made things right. At the same time there are risks and issues with any platform. It just part of trading. I know how frustrating it can be. Good luck!

 
marco.cardenas.c

Also, you should write this on the help/contact section so that the guys on Apiary can do something about it.

 
nick.spicer

Honestly I haven't had any issues since I started trading again in January. It could be anything from you connection to the sever, maybe a drop in your internet connection, a neighbour using their microwave (seriously!), to perhaps your computer restarting and not re-opening Alveo.

Absolutely nothing wrong with Apiary customer service. I agree with Dantheman and Marco.

 
mattias.norin

I have had this happen to me several times. And today it happened again. I hade moved my stop losses on two trades to break even and then they both went 30 pips below that until I turned on my computer again and it cost me 60 pips.
Also the Pips Today isnt working properly anymore. It show that I'm down 15 pips even though Ive lost 60 pips today. It was incorrect yesterday too, even since the latest update of Alveo.

 
nick.spicer

mattias.norin, FYI you have to leave Alveo open and running for your stops/trades to be triggered.

Definitely open a case with Trader Support for the pips today, keeping in mind the previous day's trades count up until the daily reset.

 
dantheman

You either have to leave Alveo open and not let your computer sleep, or you have to close Alveo. The server will execute stop losses and take profits, but there is a few minutes before the handoff is complete. So if it hits within a few minutes of Alveo being closed on your computer it can slip through before the server takes over. But if you don't close Alveo it never hands it back off to the server. So if you let you computer sleep or turn off while Alveo is running there is no program (local via Alveo on your computer or remote via the server) that will close your trades. I haven't had many issues with the server executing my SL and TPs. A handful here and there, but out of hundreds of trades I've left overnight, thats very little.

 
lah533p

Thanks for your responses. For those who have never suffered the frustration of Alveo glitches, may your luck continue to last. To the others, I share your utter frustration. I will definitely share it with support in the forelorn hope that something will be done but my experience to date has not been positive.